Проблема с Perl::DBI

Скрипты, разработка, настройка, администрирование

Модераторы: dobs, ArniXXX, hostess, bj

Ответить
Сообщение
Автор
psv
Сообщения: 4
Зарегистрирован: Сб дек 25, 2010 13:16
Контактная информация:

Проблема с Perl::DBI

#1 Сообщение psv » Ср фев 02, 2011 19:01

Судя по всему, какие-то проблемы с модулем DBI, установленным на сервере s2.ho.ua, по всей видимости, не отрабатывается директива mysql_enable_utf8 функции connect. Поэтому при выборе текста из БД и размещении его на веб-страничке, данный текст отображается "кракозябрами" (сама веб-страница тоже в utf-8).
В связи с этим вопрос: действительно ли данная проблема является проблемой сервера, и, если да, решится ли она в ближайшем будущем?

UPD: проблема решена в ходе общения с уважаемой техподдержкой, за что ей большое спасибо. Всем спасибо за внимание!
Последний раз редактировалось psv Чт фев 03, 2011 16:40, всего редактировалось 1 раз.

dobs
HO Moderators
Сообщения: 2504
Зарегистрирован: Вс апр 09, 2006 14:42
Откуда: /home/Ukraine/Kiev
Контактная информация:

#2 Сообщение dobs » Ср фев 02, 2011 19:50

Судя по

Код: Выделить всё

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
то тут явно не утф... хотя если вручную поменять то не помогает, мож сами таблицы в БД в 1251...

psv
Сообщения: 4
Зарегистрирован: Сб дек 25, 2010 13:16
Контактная информация:

#3 Сообщение psv » Ср фев 02, 2011 20:16

М. Ну, я в http-заголовке передаю браузеру charset=utf-8, в параметрах БД тоже стоит "сравнение: utf-8" (в русскоязычном phpmyadmin, как по-английский оно звучит не помню).
И браузер автоматом в кодировке утф-8 отображает, когда страничку открываешь.
Что эта мета делает, я, если честно, не знаю.
Насколько я помню, когда эксперементировал с кодировками, разные передавал в http-заголовке и смотрел потом исходный код страницы, эта самая мета не менялась никогда.
А вот кодировка странички менялась.
Поэтому я не обращаю на нее внимания.

psv
Сообщения: 4
Зарегистрирован: Сб дек 25, 2010 13:16
Контактная информация:

#4 Сообщение psv » Ср фев 02, 2011 20:17

Возможно, стоило сразу написать, описанная в первом посте проблема появилась сегодня, часов 5-8 назад.
До этого полтора месяца все работало нормально.

dobs
HO Moderators
Сообщения: 2504
Зарегистрирован: Вс апр 09, 2006 14:42
Откуда: /home/Ukraine/Kiev
Контактная информация:

#5 Сообщение dobs » Ср фев 02, 2011 20:28

Хм попробуйте написать в поддержку, вроде как сегодня утром мускул обновляли мож чет напортачили... support [at] ho.ua

psv
Сообщения: 4
Зарегистрирован: Сб дек 25, 2010 13:16
Контактная информация:

#6 Сообщение psv » Ср фев 02, 2011 20:32

dobs писал(а):Хм попробуйте написать в поддержку, вроде как сегодня утром мускул обновляли мож чет напортачили... support [at] ho.ua
Есть ли ненулевая вероятность ответа? На сайте сказано, что техподдержка бесплатного хостинга не производится. :)

dobs
HO Moderators
Сообщения: 2504
Зарегистрирован: Вс апр 09, 2006 14:42
Откуда: /home/Ukraine/Kiev
Контактная информация:

#7 Сообщение dobs » Ср фев 02, 2011 20:34

Ну думаю что должны чет ответить раз такие дела... правда уже конец дня так что скорей всего что ответят завтра... но попробовать надо) или hostes на форуме чет отпишет...

ArniXXX
HO Moderators
Сообщения: 420
Зарегистрирован: Сб янв 19, 2008 16:02
Контактная информация:

#8 Сообщение ArniXXX » Ср фев 02, 2011 22:17

Просто на днях обновляли сервер базы данных. Hostes писала сегодня на форуме про это. Возможно что потому и проблемы возникли.

Ответить